wxpython system dep

Dependency Availability

Arch Linux
All Versions
wxpython
 
CentOS
All Versions
Not available
 
Cygwin
All Versions
Not available
 
Debian
Sarge
Not available
Etch
Not available
Lenny
Not available
Squeeze
python-wxgtk2.8
Wheezy
python-wxgtk2.8
Jessie
python-wxgtk3.0
Sid (Unstable)
Not available
 
Fedora
17 (Beefy Miracle)
wxPython-devel
18 (Spherical Cow)
wxPython-devel
19 (Schrödinger's Cat)
wxPython-devel
20 (Heisenberg)
wxPython-devel
Fedora 21
wxPython-devel
Fedora 22
wxPython-devel
 
FreeBSD
All Versions
py27-wxPython
 
Gentoo Linux
All Versions
dev-python/wxpython
 
Mandrake/Mandriva Linux
All Versions
Not available
 
openSUSE
All Versions
python-wxGTK
 
Mac OS X
Leopard
Not available
Snow Leopard
Not available
Lion
Not available
Mountain lion
Not available
Mavericks
Not available
Yosemite
Not available
 
Red Hat Enterprise Linux
All Versions
Not available
 
Ubuntu
Karmic
Not available
Lucid
python-wxgtk2.8
Maverick
python-wxgtk2.8
Natty
python-wxgtk2.8
Oneiric
python-wxgtk2.8
Precise
python-wxgtk2.8
Quantal
python-wxgtk2.8
Raring
python-wxgtk2.8
Saucy
python-wxgtk2.8
Trusty
python-wxgtk2.8
Trusty (Python3)
python-wxgtk2.8
Utopic
python-wxgtk2.8
Utopic (Python3)
Not available
Vivid
python-wxgtk2.8
Vivid (Python3)
Not available
Wily
python-wxgtk2.8
Wily (Python3)
Not available
Xenial
Not available
Xenial (Python3)
Not available
 

Raw Rosdep Data

  {"arch"=>["wxpython"], "debian"=>{"buster"=>["python-wxgtk3.0"], "jessie"=>["python-wxgtk3.0"], "squeeze"=>["python-wxgtk2.8"], "stretch"=>["python-wxgtk3.0"], "wheezy"=>["python-wxgtk2.8"]}, "fedora"=>["wxPython-devel"], "freebsd"=>["py27-wxPython"], "gentoo"=>["dev-python/wxpython"], "macports"=>["py27-wxpython", "py27-gobject", "py27-gtk", "py27-cairo"], "openembedded"=>["wxpython@meta-ros"], "opensuse"=>["python-wxGTK"], "rhel"=>{"7"=>["wxPython-devel"]}, "ubuntu"=>{"*"=>["python-wxgtk3.0"], "lucid"=>["python-wxgtk2.8"], "maverick"=>["python-wxgtk2.8"], "natty"=>["python-wxgtk2.8"], "oneiric"=>["python-wxgtk2.8"], "precise"=>["python-wxgtk2.8"], "quantal"=>["python-wxgtk2.8"], "raring"=>["python-wxgtk2.8"], "saucy"=>["python-wxgtk2.8"], "trusty"=>["python-wxgtk2.8"], "trusty_python3"=>["python-wxgtk2.8"], "utopic"=>["python-wxgtk2.8"], "vivid"=>["python-wxgtk2.8"], "wily"=>["python-wxgtk2.8"]}, "osx"=>{"homebrew"=>{"packages"=>[]}}}