ruby system dep

Dependency Availability

Arch Linux
All Versions
ruby
 
CentOS
All Versions
Not available
 
Cygwin
All Versions
Not available
 
Debian
Sarge
Not available
Etch
Not available
Lenny
Not available
Squeeze
Not available
Wheezy
Not available
Jessie
ruby ruby-dev
Sid (Unstable)
Not available
 
Fedora
17 (Beefy Miracle)
ruby ruby-devel openssl-devel rubygems
18 (Spherical Cow)
ruby ruby-devel openssl-devel rubygems
19 (Schrödinger's Cat)
ruby ruby-devel openssl-devel rubygems
20 (Heisenberg)
ruby ruby-devel openssl-devel rubygems
Fedora 21
ruby ruby-devel openssl-devel rubygems
Fedora 22
ruby ruby-devel openssl-devel rubygems
 
FreeBSD
All Versions
Not available
 
Gentoo Linux
All Versions
dev-lang/ruby
 
Mandrake/Mandriva Linux
All Versions
Not available
 
openSUSE
All Versions
Not available
 
Mac OS X
Leopard
Not available
Snow Leopard
Not available
Lion
Not available
Mountain lion
Not available
Mavericks
Not available
Yosemite
Not available
 
Red Hat Enterprise Linux
All Versions
Not available
 
Ubuntu
Karmic
Not available
Lucid
ruby1.8-dev libopenssl-ruby1.8 rubygems1.8
Maverick
ruby1.8-dev libruby1.8 rubygems1.8
Natty
ruby1.8-dev libruby1.8 rubygems1.8
Oneiric
ruby1.8-dev libruby1.8 rubygems1.8
Precise
ruby1.8-dev libruby1.8 rubygems1.8
Quantal
ruby ruby-dev
Raring
ruby ruby-dev
Saucy
ruby ruby-dev
Trusty
ruby ruby-dev
Trusty (Python3)
Not available
Utopic
ruby ruby-dev
Utopic (Python3)
Not available
Vivid
ruby ruby-dev
Vivid (Python3)
Not available
Wily
ruby ruby-dev
Wily (Python3)
Not available
Xenial
ruby ruby-dev
Xenial (Python3)
Not available
 

Raw Rosdep Data

  {"osx"=>{"homebrew"=>{"packages"=>[]}}, "arch"=>["ruby"], "debian"=>{"*"=>["ruby"], "jessie"=>["ruby", "ruby-dev"], "stretch"=>["ruby", "ruby-dev"]}, "fedora"=>["ruby", "ruby-devel", "openssl-devel", "rubygems"], "gentoo"=>["dev-lang/ruby"], "macports"=>["ruby"], "ubuntu"=>{"*"=>["ruby"], "lucid"=>["ruby1.8-dev", "libopenssl-ruby1.8", "rubygems1.8"], "maverick"=>["ruby1.8-dev", "libruby1.8", "rubygems1.8"], "natty"=>["ruby1.8-dev", "libruby1.8", "rubygems1.8"], "oneiric"=>["ruby1.8-dev", "libruby1.8", "rubygems1.8"], "precise"=>["ruby1.8-dev", "libruby1.8", "rubygems1.8"], "quantal"=>["ruby", "ruby-dev"], "raring"=>["ruby", "ruby-dev"], "saucy"=>["ruby", "ruby-dev"], "trusty"=>["ruby", "ruby-dev"], "utopic"=>["ruby", "ruby-dev"], "vivid"=>["ruby", "ruby-dev"], "wily"=>["ruby", "ruby-dev"], "xenial"=>["ruby", "ruby-dev"], "yakkety"=>["ruby", "ruby-dev"], "zesty"=>["ruby", "ruby-dev"]}}