Dependency Availability

Arch Linux
All Versions
python-pyqt5
 
CentOS
All Versions
Not available
 
Cygwin
All Versions
Not available
 
Debian
Sarge
Not available
Etch
Not available
Lenny
Not available
Squeeze
Not available
Wheezy
Not available
Jessie
pyqt5-dev python3-pyqt5 python3-pyqt5.qtsvg python3-sip-dev qtbase5-dev
Sid (Unstable)
Not available
 
Fedora
17 (Beefy Miracle)
python3-qt5-devel libXext-devel
18 (Spherical Cow)
python3-qt5-devel libXext-devel
19 (Schrödinger's Cat)
python3-qt5-devel libXext-devel
20 (Heisenberg)
python3-qt5-devel libXext-devel
Fedora 21
python3-qt5-devel libXext-devel
Fedora 22
python3-qt5-devel libXext-devel
 
FreeBSD
All Versions
Not available
 
Gentoo Linux
All Versions
dev-python/PyQt5
 
Mandrake/Mandriva Linux
All Versions
Not available
 
openSUSE
All Versions
python3-qt5
 
Mac OS X
Leopard
Not available
Snow Leopard
Not available
Lion
Not available
Mountain lion
Not available
Mavericks
Not available
Yosemite
Not available
 
Red Hat Enterprise Linux
All Versions
python%{python3_pkgversion}-qt5-devel
 
Ubuntu
Karmic
Not available
Lucid
Not available
Maverick
Not available
Natty
Not available
Oneiric
Not available
Precise
Not available
Quantal
Not available
Raring
Not available
Saucy
Not available
Trusty
Not available
Trusty (Python3)
Not available
Utopic
Not available
Utopic (Python3)
Not available
Vivid
Not available
Vivid (Python3)
Not available
Wily
Not available
Wily (Python3)
Not available
Xenial
pyqt5-dev python3-pyqt5 python3-pyqt5.qtsvg python3-sip-dev
Xenial (Python3)
Not available
 

Raw Rosdep Data

  {"alpine"=>["py3-qt5"], "arch"=>["python-pyqt5"], "debian"=>{"*"=>["libpyside2-dev", "libshiboken2-dev", "pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-pyside2.qtsvg", "python3-sip-dev", "qtbase5-dev", "shiboken2"], "jessie"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev", "qtbase5-dev"], "stretch"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev", "qtbase5-dev"]}, "fedora"=>["python3-qt5-devel", "libXext-devel"], "gentoo"=>["dev-python/PyQt5"], "opensuse"=>["python3-qt5"], "rhel"=>["python%{python3_pkgversion}-qt5-devel"], "slackware"=>["python3-PyQt5"], "ubuntu"=>{"*"=>["libpyside2-dev", "libshiboken2-dev", "pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-pyside2.qtsvg", "python3-sip-dev", "shiboken2"], "artful"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "bionic"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "cosmic"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "disco"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "eoan"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "xenial"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "yakkety"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"], "zesty"=>["pyqt5-dev", "python3-pyqt5", "python3-pyqt5.qtsvg", "python3-sip-dev"]}}